您現在的位置:程序化交易>> 股票公式>> 其他>> 其他軟件公式>>正文內容

發穩操勝券系列公式組 原碼一套(僅公式、源碼)[其他軟件公式]

相關標簽:

?

發穩操勝券系列公式組 原碼一套
現發穩操勝券系列公式組特別指標原碼一套,部份公式配套發條件選股公式,望網友高手將沒有條件選股公式的補上.
原碼如下:
穩操勝券----操盤線
{p1:130300 ;p2:340300;p3:550300;p4:890300;p5:1440300;n:405;}
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.998),8);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.013),9);
STICKLINE((VAR2 < MA(VAR3,6)),CLOSE,OPEN,7,1),colorFFFF33;
STICKLINE((VAR2 < MA(VAR3,6)),LOW,(MIN(OPEN,CLOSE) * 1.001),0.6,0),colorFFFF33;
STICKLINE((VAR2 < MA(VAR3,6)),MAX(OPEN,CLOSE),HIGH,0.6,0),colorFFFF33;
STICKLINE((VAR2 > MA(VAR3,6)),OPEN,CLOSE,7,1),color4440FF;
STICKLINE((VAR2 > MA(VAR3,6)),HIGH,MAX(CLOSE,OPEN),0.6,0),color4440FF;
STICKLINE((VAR2 > MA(VAR3,6)),LOW,(MIN(CLOSE,OPEN) * 1.001),0.8,0),color4440FF;
STICKLINE(((OPEN > CLOSE) AND (VAR2 > MA(VAR3,6))),(OPEN * 0.998),(CLOSE * 1.0025),4.5,0),colorFFFF33;
STICKLINE(((OPEN < CLOSE) AND (VAR2 < MA(VAR3,6))),(CLOSE * 0.998),(OPEN * 1.0025),4.5,0),color4440FF;
STICKLINE(((OPEN > CLOSE) AND (VAR2 < MA(VAR3,6))),CLOSE,OPEN,7,0),colorFFFF33;
DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.984),'B '),color4440FF;
DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.035),'S '),colorFFFF34;
WX:=MA(CLOSE,0);
M1:MA(CLOSE,P1);
M2:(MA(CLOSE,P2) * IF((N < 2),WX,1));
M3:(MA(CLOSE,P3) * IF((N < 3),WX,1));
M4:(MA(CLOSE,P4) * IF((N < 4),WX,1));
M5:(MA(CLOSE,P5) * IF((N < 5),WX,1));


穩操勝券--底部出擊

VAR1:=(1 / WINNER(CLOSE));
A0:=MA(CLOSE,13);
VAR3:=(100 - ABS((((CLOSE - A0) / A0) * 100)));
A1:=LLV(LOW,75);
A2:=HHV(HIGH,75);
A3:=((A2 - A1) / 100);
A4:=SMA(((CLOSE - A1) / A3),20,1);
A5:=SMA(((OPEN - A1) / A3),20,1);
VAR4:=((3 * A4) - (2 * SMA(A4,15,1)));
VAR5:=((3 * A5) - (2 * SMA(A5,15,1)));
VAR6:=(100 - VAR5);
VAR7:=(100 - VAR4);
VAR8:=MA((WINNER((CLOSE * 0.95)) * 100),3);
VAR9:=(100 - IF((VAR1 > 5),IF((VAR1 < 100),VAR1,(VAR3 - 10)),0));
多方:VAR8,colorEE00EE;
空方:VAR9,colorDD00;
VAR2:=(VAR8 > VAR3);
VARA:=(REF(LOW,1) * 0.9);
VARB:=(LOW * 0.9);
VARC:=(((VARB * VOL) + (VARA * (CAPITAL - VOL))) / CAPITAL);
VARD:=EMA(VARC,30);
A6:=(CLOSE - REF(CLOSE,1));
A7:=MAX(A6,0);
A8:=ABS(A6);
VARF:=((SMA(A7,7,1) / SMA(A8,7,1)) * 100);
VAR10:=((SMA(A7,13,1) / SMA(A8,13,1)) * 100);
VAR11:=BARSCOUNT(CLOSE);
VAR12:=((SMA(MAX(A6,0),6,1) / SMA(ABS(A6),6,1)) * 100);
VAR13:=((0 - ((200 * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60)))) + 100);
VAR14:=(((CLOSE - LLV(LOW,15)) / (HHV(HIGH,15) - LLV(LOW,15))) * 100);
VAR16:=SMA(((SMA(VAR14,4,1) - 50) * 2),3,1);
VAR17:=(((INDEXC - LLV(INDEXL,14)) / (HHV(INDEXH,14) - LLV(INDEXL,14))) * 100);
VAR18:=SMA(VAR17,4,1);
VAR19:=SMA(VAR18,3,1);
VAR1A:=(((HHV(HIGH,30) - CLOSE) / CLOSE) * 100);
VAR1B:=(((((((((VAR12 <= 25) AND (VAR13 < (0 - 95))) AND (VAR1A > 20)) AND (VAR16 < (0 - 30))) AND (VAR19 < 30)) AND ((VARD - CLOSE) >= (0 - 0.25))) AND (VARF < 22)) AND (VAR10 < 28)) AND (VAR11 > 50));
VAR1C:=(((HIGH + LOW) + CLOSE) / 3);
VAR1D:=((VAR1C - MA(VAR1C,14)) / (0.015 * AVEDEV(VAR1C,14)));
VAR1E:=((VAR1C - MA(VAR1C,70)) / (0.015 * AVEDEV(VAR1C,70)));
VAR1F:=IF(((((VAR1D >= 150) AND (VAR1D < 200)) AND (VAR1E >= 150)) AND (VAR1E < 200)),10,0);
VAR20:=IF(((((VAR1D <= (0 - 150)) AND (VAR1D > (0 - 200))) AND (VAR1E <= (0 - 150))) AND (VAR1E > (0 - 200))),(0 - 10),VAR1F);
VAR21:=(IF(((VAR1E >= 200) AND (VAR1D >= 150)),15,IF(((VAR1E <= (0 - 200)) AND (VAR1D <= (0 - 150))),(0 - 15),VAR20)) + 50);
預警:VAR21,LINETHICK2,colorFFFF;
STICKLINE(VAR2,VAR3,VAR8,5,0),colorFF;
STICKLINE(1,VAR8,0,1,0),colorEE00EE;
STICKLINE(1,VAR9,100,1,0),colorDD00;
STICKLINE(VAR1B,0,80,5,0),LINETHICK3,colorFF;
DRAWTEXT((CROSS(VAR1B,0.5) AND (COUNT((VAR1B = 1),10) = 1)),20,'底部出擊'),colorFFFFFF;
DRAWTEXT((CROSS(VAR2,0.5) AND (COUNT((VAR2 = 1),10) = 1)),80,'血戰'),colorFFFFFF;


穩操勝券--底部買賣
開:((SMA(MAX((OPEN - REF(OPEN,1)),0),6,1) / SMA(ABS((OPEN - REF(OPEN,1))),6,1)) * 100),LINETHICK0;
高:((SMA(MAX((HIGH - REF(HIGH,1)),0),6,1) / SMA(ABS((HIGH - REF(HIGH,1))),6,1)) * 100),LINETHICK0;
低:((SMA(MAX((LOW - REF(LOW,1)),0),6,1) / SMA(ABS((LOW - REF(LOW,1))),6,1)) * 100),LINETHICK0;
收:((SMA(MAX((CLOSE - REF(CLOSE,1)),0),6,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),6,1)) * 100),LINETHICK0;
STICKLINE((收 > 開),高,低,0,0),colorFF;
STICKLINE((收 > 開),收,開,7,1),colorFF;
STICKLINE((收 < 開),高,低,0,0),colorFF00;
STICKLINE((收 < 開),收,開,7,0),colorFF00;
50,POINTDOT;
DRAWTEXT((((ABS((MAX(高,低) - 開)) < 14) AND ((開 - 收) > 17)) AND (REF(收,1) > 60)),80,'光頭開陰'),colorFF00;
DRAWTEXT(FILTER((((((MIN(高,低) < 20) AND (MIN(REF(高,1),REF(低,1)) < 20)) AND (MIN(REF(高,2),REF(低,2)) < 20)) AND (收 > REF(收,1))) AND (CLOSE > MA(CLOSE,120))),5),50,'買'),colorFF;
DRAWTEXT(FILTER((((MIN(高,低) < 20) AND (收 > REF(收,1))) AND (CLOSE > MA(CLOSE,120))),5),低,'買'),colorFF00FF;
DRAWTEXT(((收 - 低) > 25),(低 - 5),'火箭發射'),colorFF;
DRAWTEXT(((((MAX(高,低) > 89) AND (收 < 90)) AND (REF(收,1) > 90)) AND (REF(收,2) > 90)),10,'逃頂'),colorFF00;
DRAWTEXT(((((MAX(高,低) > 79) AND (收 < 80)) AND (REF(收,1) > 80)) AND (REF(收,2) > 80)),10,'透頂'),colorFFFF00;
DRAWTEXT(((((收 < 90) AND (開 > 90)) AND (REF(收,1) > 90)) AND (REF(收,2) > 90)),30,'天頂'),colorFF00;
DRAWTEXT((((收 < 90) AND (開 > 90)) AND (REF(收,1) > REF(收,3))),(高 + 5),'瀑布'),colorFFFF00;
DRAWTEXT((((((MIN(高,低) - ABS((收 - 開))) / ABS((高 - 低))) > 0.667) AND (收 < 80)) AND (REF(收,1) > 80)),100,'逃'),colorFFFF00;
VARS1:=REF(CLOSE,1);
VARS2:=SUM(IF((CLOSE > REF(CLOSE,1)),VOL,IF((CLOSE < REF(CLOSE,1)),(0 - VOL),0)),0);
VARS3:=REF(VARS2,1);
VARS4:=((SMA(MAX((CLOSE - VARS1),0),7,1) / SMA(ABS((CLOSE - VARS1)),7,1)) * 100);
VARS5:=((SMA(MAX((CLOSE - VARS1),0),13,1) / SMA(ABS((CLOSE - VARS1)),13,1)) * 100);
VARS6:=((SMA(MAX((VARS2 - VARS3),0),26,1) / SMA(ABS((VARS2 - VARS3)),26,1)) * 100);
VARS7:=(DATE < 1081231);
底部:IF(((((VARS4 < 15) AND (VARS5 < 20)) AND (VARS6 < 50)) AND (BARSCOUNT(CLOSE) > 25)),(0 - 100),0),STICK;
頂部:IF(((((VARS4 > 85) AND (VARS5 > 80)) AND (VARS6 > 50)) AND (BARSCOUNT(CLOSE) > 25)),100,0),STICK,LINETHICK2;
DRAWTEXT(FILTER((底部 = (0 - 100)),5),20,'底'),POINTDOT,LINETHICK2,colorFFFFFF;
DRAWTEXT(FILTER((頂部 = 100),5),80,'頂'),POINTDOT,LINETHICK2,colorFFFFFF;
VARM1:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VARM2:=(MA(CLOSE,20) + (2 * STD(CLOSE,20)));
VARM3:=REF(CLOSE,1);
VARM4:=((SMA(MAX((CLOSE - VARM3),0),7,1) / SMA(ABS((CLOSE - VARM3)),7,1)) * 100);
VARM5:=CROSS(79,VARM4);
VARM6:=FILTER(VARM5,4);
賣出:=IF(CROSS(VARM1,VARM2),1,0);
STICKLINE((賣出 = 1),90,100,10,1),LINETHICK3,colorFF0000;
MCB:=IF(VARM6,1,0);
STICKLINE((MCB = 1),90,100,10,1),LINETHICK3,colorFFFFFF;


穩操勝券--搏殺生命
AMV0:=((VOL * (OPEN + CLOSE)) / 2);
BS:(SUM(AMV0,88) / SUM(VOL,88)),LINETHICK2,colorFF00FF;
STICKLINE((CLOSE >= OPEN),OPEN,CLOSE,5,1),colorFF;
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,5,0),colorFF00;
STICKLINE((CLOSE >= OPEN),CLOSE,HIGH,0.5,1),colorFF;
STICKLINE((CLOSE >= OPEN),OPEN,LOW,0.5,1),colorFF;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,0.5,0),colorFF00;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,0.5,0),colorFF00;


穩操勝券--底部支撐
VAR4:=(((LOW + HIGH) + CLOSE) / 3);
操作:MA(VAR4,5),LINETHICK2,colorFFFFFF;
拉升:HHV(操作,13),LINETHICK1,colorFF;
壓力:HHV(操作,60),colorFF;
買賣:LLV(操作,13),LINETHICK1,colorFF00;
底部支撐:(LLV(LOW,60) * 1.02),colorCCFF;
頂部:(HHV(HIGH,60) * 0.98),colorFFFFCC;
STICKLINE((操作 > REF(操作,1)),操作,(操作 + 0.018),5,0),LINETHICK4,colorFFFF;
STICKLINE((拉升 > REF(拉升,1)),拉升,(拉升 + 0.018),5,0),LINETHICK2,colorFFFF;
STICKLINE((拉升 = REF(拉升,1)),拉升,拉升,1,1),colorFF;
STICKLINE((買賣 = REF(買賣,1)),買賣,買賣,1,1),colorFF;
STICKLINE((買賣 > REF(買賣,1)),買賣,(買賣 + 0.028),4,1),LINETHICK2,colorF00FF0;
STICKLINE((頂部 = REF(頂部,1)),頂部,頂部,7,1),colorFF;
STICKLINE((壓力 = REF(壓力,1)),壓力,壓力,7,1),colorFF;
STICKLINE((底部支撐 = REF(底部支撐,1)),底部支撐,底部支撐,1,1),colorFF;


穩操勝券--輔助指標
VAR1:=(((CLOSE - LLV(LOW,100)) / (HHV(HIGH,100) - LLV(LOW,100))) * 200);
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=((3 * VAR2) - (2 * VAR3));
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=(EMA((((CLOSE - VAR5) / (VAR6 - VAR5)) * 100),4) * 2);
VAR8:=EMA(((0.667 * REF(VAR7,1)) + (0.333 * VAR7)),2);
VAR9:=((3 * VAR7) - (2 * VAR8));
VARA:=(POW(MA(CLOSE,5),2) + MA(CLOSE,5));
VARB:=(POW(MA(LOW,5),2) + MA(LOW,5));
VARC:=(POW(MA(HIGH,5),2) + MA(HIGH,5));
VARD:=(((((VARA - LLV(VARB,64)) / (HHV(VARC,64) - LLV(VARB,64))) * 150) + 65) - 10);
VARE:=((SMA(VARD,3,1) * 1.5) - 100);
VARF:=SMA(VARE,3,1);
VAR10:=((3 * VARE) - (2 * VARF));
VAR11:=(((HIGH + LOW) + (CLOSE * 2)) / 4);
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(((VAR11 - VAR12) * 100) / VAR13);
VAR15:=EMA(VAR14,5);
VAR16:=EMA(VAR15,13);
VAR17:=((EMA(VAR15,13) + 200) - 100);
VAR18:=EMA(VAR17,10);
VAR19:=((3 * VAR17) - (2 * VAR18));
VAR1A:=(((VAR2 + VAR7) + VARE) + VAR17);
VAR1B:=(((VAR3 + VAR8) + VARF) + VAR18);
VAR1C:=(((VAR4 + VAR9) + VAR10) + VAR19);
VAR1D:=(((HIGH + LOW) + CLOSE) / 3);
VAR1E:=((AMOUNT / VOL) / 100);
VAR1F:=((SUM(AMOUNT,5) / SUM(VOL,5)) / 100);
VAR20:=((VAR1D - MA(VAR1D,34)) / (0.015 * AVEDEV(VAR1D,34)));
VAR21:=DMA(((AMOUNT / VOL) / 100),(VOL / CAPITAL));
VAR22:=((((HIGH + LOW) + CLOSE) + VAR1D) / 4);
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(((VAR22 - VAR23) / VAR24) * 100);
VAR26:=((VAR1D - MA(VAR1D,24)) / (0.015 * AVEDEV(VAR1D,24)));
VAR27:=EMA(VAR25,5);
VAR28:=((VAR1E - MA(VAR1E,21)) / (0.015 * AVEDEV(VAR1E,21)));
VAR29:=((VAR1F - MA(VAR1F,90)) / (0.015 * AVEDEV(VAR1F,90)));
VAR2A:=(((((((VAR29 + VAR28) + VAR27) + VAR26) + VAR20) / 5) + 165) / 4);
VAR2B:=(((((VAR1A + VAR1B) + (VAR1C * 30)) / 32) / 5) - 15);
VAR2C:=(((VAR2A + VAR2B) / 2) / 1.1);
短線:VAR2C,colorFF;
MID:MA(短線,26),colorFFFFFF;
UPPER:(MID + (2 * STD(短線,26)));
LOWER:(MID - (2 * STD(短線,26))),colorF00FF0;
IF((短線 > MID),MID,短線),colorFF00;
買點:DRAWICON(CROSS(短線,MID),(MID * 0.97),10);
DRAWICON(CROSS(短線,LOWER),(LOWER * 0.97),4);
賣點:DRAWICON(CROSS(UPPER,短線),(UPPER * 0.97),12);
MID,colorFF0000;

穩操勝券--均線系統
快速上漲1:MA(CLOSE,888),colorFF;
密切關注:MA(CLOSE,99),colorFFFF;
牛股開始1:MA(CLOSE,318),colorFF00;
大453:MA(CLOSE,453),color1;
上升突破:MA(CLOSE,610),color99FF;

穩操勝券------買入
趨勢:(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),colorFF00;
VAR1:=FORCAST(CLOSE,30);
主力:(WINNER(VAR1) * 100),colorFFFF;
啟:(CROSS(趨勢,主力) AND (REF(趨勢,1) < 30)),POINTDOT,colorFF00;
SZ1:=(CROSS(趨勢,30) AND (趨勢 > 主力));
SZ2:=(CROSS(趨勢,50) AND (COUNT((趨勢 > REF(趨勢,1)),2) = 2));
漲:(SZ1 OR SZ2),POINTDOT,colorFF;
強:CROSS(趨勢,70),POINTDOT,colorFFFF;
回:(CROSS(70,趨勢) AND (趨勢 > 50)),POINTDOT,colorFFFFFF;
險:(趨勢 > 95),POINTDOT,colorFF;
STICKLINE((CLOSE > 0),95,95,4,0),colorFF;
STICKLINE((CLOSE > 0),30,30,4,0),colorFFFFFF;
STICKLINE(啟,0,10,4,0),colorFF00;
DRAWTEXT(啟,20,'啟'),colorFF00;
STICKLINE(漲,0,30,4,0),colorFFFF;
DRAWTEXT(漲,20,'漲'),colorFF;
STICKLINE(強,70,90,4,0),colorFF00FF;
DRAWTEXT(強,85,'強'),colorFF00;
STICKLINE(回,70,50,4,0),colorFFFFFF;
DRAWTEXT(回,65,'回'),colorFF00;
STICKLINE((趨勢 >= 70),90,95,4,1),colorFFFF;
STICKLINE((趨勢 >= 95),95,100,4,1),colorFF;
STICKLINE((趨勢 <= 10),0,10,4,1),colorFF6600;

穩操勝券----買提示
MA5:EMA(CLOSE,5),colorFFFFFF;
工作線:EMA(CLOSE,14),LINETHICK1,colorF00FF0;
二號線:EMA(CLOSE,25),LINETHICK1,colorFF00;
九號線:EMA(CLOSE,99),LINETHICK1;
MA120:EMA(CLOSE,120),LINETHICK1;
生命線:EMA(CLOSE,453),LINETHICK1,colorFF;
DIFF:=(EMA(CLOSE,7) - EMA(CLOSE,19));
DEA:=EMA(DIFF,9);
MACD:=(0.9 * (DIFF - DEA));
TJ:=(DIFF >= DEA);
TJ1:=(DIFF >= 0);
STICKLINE(TJ,HIGH,LOW,0.5,0),colorFFFF;
STICKLINE(TJ,OPEN,CLOSE,4,0),colorFFFF;
STICKLINE((TJ1 AND TJ),HIGH,LOW,0.5,0),colorF00FF0;
STICKLINE((TJ1 AND TJ),OPEN,CLOSE,4,1),colorF00FF0;
STICKLINE((DIFF < DEA),HIGH,LOW,0.5,0),colorF0F000;
STICKLINE((DIFF < DEA),OPEN,CLOSE,4,0),colorF0F000;
VAR1:=((((CLOSE * 2) + HIGH) + LOW) / 4);
SK:=(EMA(VAR1,13) - EMA(VAR1,73));
SD:=EMA(SK,2);
DRAWTEXT(((((CROSS(SK,SD) AND (SK < (0 - 0.04))) AND (((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) >= 0.03)) OR (CROSS(SK,SD) AND (SK <= (0 - 0.14)))) OR ((CROSS(SK,SD) AND (SK <= 0.05)) AND (((VOL / MA(VOL,5)) > 2) OR ((CLOSE / REF(CLOSE,1)) > 0.035)))),(LOW * 0.99),'短線'),colorFF;
STICKLINE(((((CROSS(SK,SD) AND (SK < (0 - 0.04))) AND (((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) >= 0.03)) OR (CROSS(SK,SD) AND (SK <= (0 - 0.14)))) OR ((CROSS(SK,SD) AND (SK <= 0.05)) AND (((VOL / MA(VOL,5)) > 2) OR ((CLOSE / REF(CLOSE,1)) > 0.035)))),HIGH,LOW,0.5,0),colorFF;
STICKLINE(((((CROSS(SK,SD) AND (SK < (0 - 0.04))) AND (((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) >= 0.03)) OR (CROSS(SK,SD) AND (SK <= (0 - 0.14)))) OR ((CROSS(SK,SD) AND (SK <= 0.05)) AND (((VOL / MA(VOL,5)) > 2) OR ((CLOSE / REF(CLOSE,1)) > 0.035)))),OPEN,CLOSE,10,1),LINETHICK3,colorFF;


穩操勝券--買主升浪
VAR3:=LLV(HIGH,240);
VAR4:=((100 * (CLOSE - VAR3)) / VAR3);
VAR5:=REF(LLV(CLOSE,480),1);
VAR6:=REF(HHV(CLOSE,480),1);
VAR7:=((100 * (CLOSE - VAR5)) / (VAR6 - VAR5));
VAR8:=(((CLOSE - LLV(CLOSE,981)) / (HHV(CLOSE,981) - LLV(CLOSE,981))) * 100);
VAR9:=(((CLOSE - LLV(CLOSE,393)) / (HHV(CLOSE,393) - LLV(CLOSE,393))) * 100);
VARA:=(((CLOSE - LLV(LOW,981)) / (HHV(HIGH,981) - LLV(LOW,981))) * 100);
VARB:=(((CLOSE - LLV(LOW,393)) / (HHV(HIGH,393) - LLV(LOW,393))) * 100);
VARC:=(EMA(((100 * (CLOSE - LLV(LOW,100))) / (HHV(HIGH,100) - LLV(LOW,100))),5) / 4);
VARD:=IF((DATE < 1031231),IF((VARC > 23.16),VARC,0),0);
VARE:=(VARC < 1);
VARF:=VARD;
VAR10:=((VAR4 < 0) AND (VAR7 < 0));
VAR11:=1;
VAR12:=((((HIGH + LOW) + (CLOSE * 2)) / 4) * VAR11);
VAR13:=EMA(VAR12,21);
VAR14:=STD(VAR12,21);
VAR15:=((((((VAR12 - VAR13) / VAR14) * 100) + 200) / 4) * VAR11);
VAR16:=(((EMA(VAR15,89) - 25) * 1.56) * VAR11);
VAR17:=((EMA(VAR16,5) * 1.22) * VAR11);
VAR18:=(EMA(VAR17,3) * VAR11);
VAR19:=((3 * VAR17) - ((2 * VAR18) * VAR11));
VAR1A:=IF(((CROSS(VAR19,VAR17) AND CROSS(VAR19,VAR18)) AND CROSS(VAR17,VAR18)),1,0);
VAR1B:=IF(((CROSS(VAR17,VAR19) AND CROSS(VAR18,VAR19)) AND CROSS(VAR18,VAR17)),1,0);
買點:IF((FILTER(((((VAR8 = 0) AND VARE) AND VAR10) AND VAR1A),5) = 1),10,0),colorFF;
賣點:IF((FILTER((((VAR8 = 100) AND VARF) AND VAR1B),5) = 1),10,0),colorFF00;
VAR1C:=(EMA(((100 * (CLOSE - LLV(LOW,100))) / (HHV(HIGH,100) - LLV(LOW,100))),13) / 4);
VAR1D:=(EMA(CLOSE,2) - EMA(CLOSE,89));
VAR1E:=EMA(VAR1D,30);
VAR1F:=((2 * (VAR1D - VAR1E)) * 10);
VAR20:=((POW(VAR1F,3) * 0.1) + POW(VAR1F,2));
VAR21:=SQRT(SQRT((((LOW * HIGH) * OPEN) * CLOSE)));
VAR22:=EMA((VAR21 * 0.97),3);
VAR23:=(((HIGH + LOW) + CLOSE) / 3);
VAR24:=((VAR23 - MA(VAR23,14)) / (0.015 * AVEDEV(VAR23,14)));
VAR25:=(IF(((YEAR < 2008) AND (VAR1F > 0.015)),VAR20,0) / 45);
莊拉線:VAR25,colorFFFF;
VAR26:=(EMA(CLOSE,2) - EMA(CLOSE,150));
VAR27:=EMA(VAR26,100);
VAR28:=(2 * (VAR26 - VAR27));
VAR29:=((POW(VAR28,3) * 0.1) + POW(VAR28,1));
VAR2A:=SQRT(SQRT((((LOW * HIGH) * OPEN) * CLOSE)));
VAR2B:=EMA((VAR2A * 0.97),3);
VAR2C:=(((HIGH + LOW) + CLOSE) / 3);
VAR2D:=((VAR2C - MA(VAR2C,14)) / (0.015 * AVEDEV(VAR2C,14)));
黑馬線:(IF((VAR28 > 0.1),VAR29,0) * 5),colorFF;
量價線:(((CLOSE - MA(CLOSE,21)) / MA(CLOSE,21)) * 100),colorFFFFFF;
VAR2E:=IF((FILTER(((量價線 > 0) AND (量價線 < 3)),5) = 1),12,0);
漲幅前兆:IF((FILTER(((((莊拉線 > 0) AND (莊拉線 < 0.5)) AND VAR2E) AND (VAR1C < 3)),10) = 1),10,0),colorFFFFFF;
選股利器:IF((FILTER((((((((VAR2E > 0) AND (VAR1C < 2)) AND (莊拉線 > 0)) AND (莊拉線 < 1)) AND (黑馬線 > 0)) AND (黑馬線 < 1.5)) AND (VAR2E > 0)),5) = 1),10,0),colorFF00FF;
DRAWICON((買點 > 0),10,1);
DRAWICON((賣點 > 0),10,2);
DRAWICON((漲幅前兆 > 0),10,1);
DRAWICON((選股利器 > 0),10,1);
量價先行:(10 * CROSS(量價線,0)),colorFF00;
DRAWICON((量價先行 > 0),10,11);
拉升開始:(15 * (((((((莊拉線 > 0.1) AND (COUNT((莊拉線 > 0.1),2) = 1)) AND (CLOSE >= OPEN)) AND (VOL > REF(VOL,1))) AND ((VOL / CAPITAL) > 0.003)) AND (量價線 > 1)) AND (量價線 > 黑馬線))),LINETHICK2,colorFFFF;
DRAWICON((拉升開始 > 0),15,10);
量價主升浪:(20 * FILTER((CROSS(量價線,黑馬線) AND (莊拉線 > 0.5)),7)),LINETHICK3,colorFF00;
DRAWICON((量價主升浪 > 0),20,8);
莊拉主升浪:(30 * ((CROSS(莊拉線,黑馬線) AND (黑馬線 > 0)) AND (量價線 > 0))),LINETHICK3,colorFF;
DRAWICON((莊拉主升浪 > 0),30,8);


穩操勝券------逃頂
input:N(34,1,500),M(3,1,500);
大盤生命指數:(EMA(((100 * (CLOSE - LLV(LOW,N))) / (HHV(HIGH,N) - LLV(LOW,N))),M) / 4);
大盤生命量能:IF((大盤生命指數 > 23.16),大盤生命指數,15),CIRCLEDOT;
強勢:23;
生命線:3;

穩操勝券新股追蹤器
VAR1:=HHV(HIGH,3);
VAR2:=((IF((WINNER((1.1 * CLOSE)) < 0),0,WINNER((1.1 * CLOSE))) - IF((WINNER((0.9 * CLOSE)) < 0),0,WINNER((0.9 * CLOSE)))) * 100);
VAR3:=IF((VAR1 < 0),0,VAR1);
VAR4:=IF((VAR2 < 0),0,VAR2);
震倉:(PWINNER(10,VAR4) * 100),CROSSDOT,LINETHICK1,colorFFFFFF;
V1:=LLV(LOW,10);
V2:=HHV(HIGH,25);
價位線:=EMA((((CLOSE - V1) / (V2 - V1)) * 4),4);
買入:STICKLINE(CROSS(價位線,0.3),50,5,2,0),LINETHICK1,colorCCFF;
STICKLINE(CROSS(價位線,0.3),30,5,2,0),LINETHICK1,colorFF;
賣出:STICKLINE(CROSS(3.5,價位線),60,100,2,0),LINETHICK2,colorFF;
STICKLINE(CROSS(3.5,價位線),80,100,2,0),LINETHICK2,colorFF9900;
DRAWTEXT(CROSS(價位線,0.3),55,'買'),colorF00FF0;
DRAWTEXT(CROSS(3.5,價位線),55,'賣'),colorFF00;
VAR2Q:=REF(LOW,1);
VAR3Q:=((SMA(ABS((LOW - VAR2Q)),3,1) / SMA(MAX((LOW - VAR2Q),0),3,1)) * 100);
VAR4Q:=EMA(IF((CLOSE * 1.3),(VAR3Q * 10),(VAR3Q / 10)),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=((EMA(IF((LOW <= VAR5Q),((VAR4Q + (VAR6Q * 2)) / 2),0),3) / 618) * VAR7Q);
VAR9Q:=IF((VAR8Q > 100),100,VAR8Q);
吸籌:STICKLINE((VAR9Q > (0 - 120)),0,VAR9Q,6,1),colorFFFF;
AA3:=((((HHV(HIGH,21) - CLOSE) / (HHV(HIGH,21) - LLV(LOW,21))) * 100) - 10);
AA4:=(((CLOSE - LLV(LOW,21)) / (HHV(HIGH,21) - LLV(LOW,21))) * 100);
AA5:=SMA(AA4,13,8);
走勢:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);
賣臨界:STICKLINE(((走勢 - AA6) > 85),98,90,15,1),colorFFFF00;

穩操勝券----漲停王
量:=REF(CLOSE,REF(HHVBARS(VOL,21),0));
M1:=MA(CLOSE,1);
A:=(((VOL > (1 * REF(VOL,1))) AND ((((CLOSE / REF(CLOSE,1)) - 1) * 100) > 9.5)) AND (M1 >= 量));
DRAWICON(CROSS(A,1),(LOW * 0.98),3),colorFFFFFF;
DRAWTEXT(A,(LOW * 0.93),'漲停王'),LINETHICK1,colorFFFF;

穩操勝券--主力進場

VAR2:=REF(LOW,1);
VAR3:=((SMA(ABS((LOW - VAR2)),13,1) / SMA(MAX((LOW - VAR2),0),13,1)) * 100);
VAR4:=EMA(IF((CLOSE * 1.2),(VAR3 * 13),(VAR3 / 13)),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=((EMA(IF((LOW <= VAR5),((VAR4 + (VAR6 * 2)) / 2),0),3) / 618) * VAR7);
VAR9:=EMA(CLOSE,5);
VAR10:=(((CLOSE - MA(CLOSE,34)) / MA(CLOSE,34)) * (0 - 10));
STICKLINE((VAR9 > REF(VAR9,1)),0,(VAR9 * 0.08),4,1),color10E410;
減倉:IF((VAR9 > REF(VAR9,1)),VAR9,0),LINETHICK0,color10E410;
STICKLINE((VAR9 < REF(VAR9,1)),0,(VAR9 * 0.08),4,1),color1010FF;
增倉:IF((VAR9 < REF(VAR9,1)),VAR9,0),LINETHICK0,color1010FF;
STICKLINE((VAR8 > REF(VAR8,1)),0,VAR8,4,1),color10FFFF;
主力進場:IF((VAR8 > REF(VAR8,1)),(VAR8 * 8),0),LINETHICK0,color10FFFF;
STICKLINE((VAR8 < REF(VAR8,1)),0,VAR8,4,1),colorFFF810;
洗緩:IF((VAR8 < REF(VAR8,1)),(VAR8 * 10),0),LINETHICK0,colorFFF810;
主力持倉:(LOW * 5),LINETHICK0,colorFF10FF;
增減力度:VAR10,colorFF7676;
XL1:=(MA(LOW,2) * 0.96);
XL2:=(MA(LOW,26) * 0.85);
XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2)));
STICKLINE(XL3,0,(VAR8 * 3),4,0),color6EFF;
DRAWTEXT(XL3,(VAR8 * 2),'買'),color6EFF;
↑買:DRAWICON(XL3,0,4),colorFF;

主力進場選股


input:MA1(148,1,500);
TJ1:=MA(CLOSE,148);
XL1:=(MA(LOW,2) * 0.96);
XL2:=(MA(LOW,26) * 0.85);
XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2)));
(XL3 AND (CLOSE > TJ1));

穩操勝券------追漲
RSV:=(((HHV(HIGH,13) - CLOSE) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,5,1);
STICKLINE((LWR1 >= LWR2),HIGH,LOW,0.05,0),colorFFDDC0;
STICKLINE((LWR1 >= LWR2),OPEN,CLOSE,5,0),colorFFDDC0;
STICKLINE((LWR1 < LWR2),HIGH,LOW,0.05,0),colorFF;
STICKLINE((LWR1 < LWR2),OPEN,CLOSE,5,1),colorFF;
VAR3AA:=IF((CLOSE > REF(CLOSE,1)),88,0);
VAR4AA:=IF(((((CLOSE / REF(CLOSE,1)) > 1.05) AND ((HIGH / CLOSE) < 1.01)) AND (VAR3AA > 0)),91,0);
DRAWTEXT(FILTER((VAR4AA > 90),34),(LOW * 0.95),'買'),colorFFFF;
DRAWTEXT(FILTER((VAR4AA > 90),34),(LOW * 0.99),'▲'),colorFFFF;
EMA30:EMA(CLOSE,30),colorFFFF;
EMA60:EMA(CLOSE,60),color4080FF;
EMA90:EMA(CLOSE,90),colorC08000;
EMA120:EMA(CLOSE,120),color8080;
SS:=((((((CROSS(EMA30,EMA60) AND (CLOSE > OPEN)) AND (CLOSE > REF(CLOSE,1))) AND ((CLOSE / REF(CLOSE,1)) >= 1.018)) OR (((CROSS(EMA30,EMA120) AND (CLOSE > OPEN)) AND (CLOSE > REF(CLOSE,1))) AND ((CLOSE / REF(CLOSE,1)) >= 1.018))) OR (((CROSS(EMA60,EMA90) AND (CLOSE > OPEN)) AND (CLOSE > REF(CLOSE,1))) AND ((CLOSE / REF(CLOSE,1)) >= 1.018))) OR (((CROSS(EMA30,EMA90) AND (CLOSE > OPEN)) AND (CLOSE > REF(CLOSE,1))) AND ((CLOSE / REF(CLOSE,1)) >= 1.018)));
DRAWICON(SS,(LOW - 0.04),1);
FA:=(BARSLAST(CROSS(MA(CLOSE,60),MA(CLOSE,20))) AND CROSS(MA(CLOSE,20),MA(CLOSE,60)));
STICKLINE(FA,MA(CLOSE,20),(MA(CLOSE,20) - 0.09),4,0),colorFFFFFF;
DRAWTEXT(FA,(MA(CLOSE,20) - 0.13),'握↑手'),colorFFFFFF;
TT1:=((CROSS(MA(CLOSE,20),MA(CLOSE,120)) AND CROSS(MA(CLOSE,20),MA(CLOSE,250))) AND (VOL > REF(VOL,1)));
TT2:=(((MA(CLOSE,20) > REF(MA(CLOSE,20),2)) AND (VOL > REF(VOL,1))) AND CROSS(CLOSE,MA(CLOSE,20)));
DRAWTEXT(TT1,(LOW - 0.13),'金叉'),colorFFFF;
STICKLINE(TT2,LOW,(LOW - 0.09),4,0),colorFFFF;
DRAWTEXT(TT2,(LOW - 0.13),'買'),colorFFFF;
STICKLINE(((((MA(CLOSE,120) >= REF(MA(CLOSE,120),1)) AND CROSS(CLOSE,MA(CLOSE,20))) AND CROSS(CLOSE,MA(CLOSE,120))) AND (VOL > REF(VOL,1))),LOW,(LOW - 0.09),4,0),colorFF00FF;
DRAWTEXT(((((MA(CLOSE,120) >= REF(MA(CLOSE,120),1)) AND CROSS(CLOSE,MA(CLOSE,20))) AND CROSS(CLOSE,MA(CLOSE,120))) AND (VOL > REF(VOL,1))),(LOW - 0.13),'買'),colorFF00FF;


穩操勝券--莊家顯身
VAR2:=REF(LOW,1);
VAR3:=((SMA(ABS((LOW - VAR2)),3,1) / SMA(MAX((LOW - VAR2),0),3,1)) * 100);
VAR4:=EMA(IF((CLOSE * 1.2),(VAR3 * 10),(VAR3 / 10)),3);
VAR5:=LLV(LOW,38);
VAR6:=HHV(VAR4,38);
VAR7:=IF(LLV(LOW,90),1,0);
VAR8:=((EMA(IF((LOW <= VAR5),((VAR4 + (VAR6 * 2)) / 2),0),3) / 618) * VAR7);
有莊的影子:STICKLINE(VAR8,0,VAR8,6,1),colorFFAAFF;
趨勢線:(((CLOSE - MA(CLOSE,40)) / MA(CLOSE,40)) * 100),colorAABBDD;
AA:=(((((REF(趨勢線,1) < REF(趨勢線,2)) AND (趨勢線 < (0 - 30))) AND (趨勢線 >= REF(趨勢線,1))) OR (REF(CROSS((0 - 30),趨勢線),1) AND CROSS(趨勢線,(0 - 30)))) OR (趨勢線 = (0 - 30)));
DRAWTEXT(AA,500,'砸鍋賣田買'),colorFFFF;
砸鍋賣田買:IF(AA,500,(0 - 30)),colorFFFF;
BB:=(((((REF(趨勢線,1) < REF(趨勢線,2)) AND (趨勢線 < (0 - 20))) AND (趨勢線 > (0 - 25))) AND (趨勢線 >= REF(趨勢線,1))) OR (REF(CROSS((0 - 20),趨勢線),1) AND CROSS(趨勢線,(0 - 20))));
DRAWTEXT(BB,300,'見底信號'),colorFF;
見底信號:IF(BB,300,(0 - 20)),colorFF;
CC:=(((((REF(趨勢線,1) < REF(趨勢線,2)) AND (趨勢線 < (0 - 25))) AND (趨勢線 > (0 - 30))) AND (趨勢線 >= REF(趨勢線,1))) OR (REF(CROSS((0 - 25),趨勢線),1) AND CROSS(趨勢線,(0 - 25))));
DRAWTEXT(CC,400,'莫錯失機會'),colorFF00;
莫錯失機會:IF(CC,400,(0 - 25)),colorFF00;
底部快顯:IF(CROSS((0 - 20),趨勢線),100,(0 - 20)),LINETHICK2,colorF0F000;
DRAWTEXT(CROSS((0 - 20),趨勢線),120,''),colorF0F000;
機會來臨:IF(CROSS((0 - 25),趨勢線),150,(0 - 25)),LINETHICK2,colorF00FF0;
DRAWTEXT(CROSS((0 - 25),趨勢線),170,''),colorF00FF0;
砸鍋賣田等:IF(CROSS((0 - 30),趨勢線),200,(0 - 30)),LINETHICK2,colorFFFFFF;
DRAWTEXT(CROSS((0 - 30),趨勢線),220,''),colorFFFFFF;
(0 - 20),POINTDOT,colorFF;
(0 - 25),POINTDOT,color1;
(0 - 30),POINTDOT,colorFFFF;

穩操勝券----高級版
{n:161 20 ; m: 3120;}
R:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),N);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),N);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),N);
PDI:((DMP * 100) / TR);
MDI:((DMM * 100) / TR);
ADX:MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),M);
ADXR:((ADX + REF(ADX,M)) / 2);
預警:IF(((ADX > 90) AND (PDI = 0)),30,0),LINETHICK2,colorFFFF;
買:IF((((CROSS(PDI,MDI) AND ((CLOSE > (1.05 * REF(CLOSE,1))) OR (REF(CLOSE,1) > (1.05 * REF(CLOSE,2))))) AND ((VOL > (2 * REF(VOL,1))) OR (REF(VOL,1) > (2 * REF(VOL,2))))) AND (MA(VOL,5) > MA(VOL,60))),20,0),LINETHICK2,colorFF;
買2:IF((CROSS(PDI,MDI) AND (COUNT(預警,10) >= 1)),10,0),LINETHICK3,colorFF00FF;


穩操勝券高級版選股
{n:161 20 ; m: 3120;}
R:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),N);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),N);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),N);
PDI:=((DMP * 100) / TR);
MDI:=((DMM * 100) / TR);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),M);
ADXR:=((ADX + REF(ADX,M)) / 2);
買:=IF((((CROSS(PDI,MDI) AND ((CLOSE > (1.05 * REF(CLOSE,1))) OR (REF(CLOSE,1) > (1.05 * REF(CLOSE,2))))) AND ((VOL > (2 * REF(VOL,1))) OR (REF(VOL,1) > (2 * REF(VOL,2))))) AND (MA(VOL,5) > MA(VOL,60))),20,0);
((((PDI > MDI) AND (PDI > ADX)) AND (PDI > ADXR)) AND (買 > 1));


穩操勝券機構版A
{n:401100;m:31100;}
R:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),N);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),N);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),N);
PDI:((DMP * 100) / TR);
MDI:((DMM * 100) / TR);
ADX:MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),M);
ADXR:((ADX + REF(ADX,M)) / 2);
預警:IF(((ADX > 90) AND (PDI = 0)),30,0),LINETHICK2,colorFFFF;
買:IF((((CROSS(PDI,MDI) AND ((CLOSE > (1.05 * REF(CLOSE,1))) OR (REF(CLOSE,1) > (1.05 * REF(CLOSE,2))))) AND ((VOL > (2 * REF(VOL,1))) OR (REF(VOL,1) > (2 * REF(VOL,2))))) AND (MA(VOL,5) > MA(VOL,60))),20,0),LINETHICK2,colorFF;
買2:IF((CROSS(PDI,MDI) AND (COUNT(預警,10) >= 1)),10,0),LINETHICK0,colorFF00FF;


穩操勝券機構版A選股
{n:401200;m:31200;}
R:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),N);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),N);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),N);
PDI:=((DMP * 100) / TR);
MDI:=((DMM * 100) / TR);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),M);
ADXR:=((ADX + REF(ADX,M)) / 2);
買:=IF((((CROSS(PDI,MDI) AND ((CLOSE > (1.05 * REF(CLOSE,1))) OR (REF(CLOSE,1) > (1.05 * REF(CLOSE,2))))) AND ((VOL > (2 * REF(VOL,1))) OR (REF(VOL,1) > (2 * REF(VOL,2))))) AND (MA(VOL,5) > MA(VOL,60))),20,0);

穩操勝券---機構版B
{n:501100;m:51100;}

R:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),N);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),N);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),N);
PDI:((DMP * 100) / TR);
MDI:((DMM * 100) / TR);
ADX:MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),M);
ADXR:((ADX + REF(ADX,M)) / 2);
預警:IF(((ADX > 90) AND (PDI = 0)),30,0),LINETHICK2,colorFFFF;
買:IF((((CROSS(PDI,MDI) AND ((CLOSE > (1.05 * REF(CLOSE,1))) OR (REF(CLOSE,1) > (1.05 * REF(CLOSE,2))))) AND ((VOL > (2 * REF(VOL,1))) OR (REF(VOL,1) > (2 * REF(VOL,2))))) AND (MA(VOL,5) > MA(VOL,60))),20,0),LINETHICK2,colorFF;
買2:IF((CROSS(PDI,MDI) AND (COUNT(預警,10) >= 1)),10,0),LINETHICK0,colorFF00FF;
((((PDI > MDI) AND (PDI > ADX)) AND (PDI > ADXR)) AND (買 > 1));

穩操勝券機構版B選股
{n:501200;m:51200;}
R:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),N);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),N);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),N);
PDI:=((DMP * 100) / TR);
MDI:=((DMM * 100) / TR);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),M);
ADXR:=((ADX + REF(ADX,M)) / 2);
買:=IF((((CROSS(PDI,MDI) AND ((CLOSE > (1.05 * REF(CLOSE,1))) OR (REF(CLOSE,1) > (1.05 * REF(CLOSE,2))))) AND ((VOL > (2 * REF(VOL,1))) OR (REF(VOL,1) > (2 * REF(VOL,2))))) AND (MA(VOL,5) > MA(VOL,60))),20,0);
((((PDI > MDI) AND (PDI > ADX)) AND (PDI > ADXR)) AND (買 > 1));<!--++ plugin_code qcomic begin--><!--++ plugin_code qcomic end-->

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,謝謝您!)

怎么收費,代編流程等詳情請點擊閱讀,或QQ微信聯系我們!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  输入号码查询新疆35选7 云南快乐10分中奖说明 体育彩票历史开奖记录 飞鱼奖 辽宁快乐12开奖结果 福彩快乐8开奖官网 福彩排列7历年开奖结果 体彩上海11选5手机版 网上炒股配资推选尚牛在线 内蒙古十一选五的漏洞 天天中彩票谁中了604万 时时彩专业计划稳定版 配资炒股合法吗 江西快3开奖结果走势闺 江西多乐开奖结果查询 河北11选五一定牛跨度 股票涨跌的依据