您現在的位置:程序化交易>> 股票公式>> 其他>> 其他軟件公式>>正文內容

q天驕條件選股公式組[其他軟件公式]

相關標簽:

?

文件:q天驕公式組_hy.alg
名稱: L天驕1號 類別:條件選股
說明: ******抄底公式
公式組: 力量

?

原理解析:


?

?來源:程序化99( www.39222826.buzz )

源碼:

?



LL1:=INDEXC;
LL2:=REF(INDEXC,1);
LL3:=REF(CLOSE,1);
LL4:=REF(OPEN,1);
LL5:=REF(LOW,1);
LL6:=HHV(HIGH,5);
LL7:=LLV(LOW,5);
LL8:=(HIGH+LOW+CLOSE*2)/4;
LL9:=(HIGH+LOW)/2;
LL10:=VOL/CAPITAL*100;
LIL1:=(SMA(MAX(CLOSE-LL3,0),6,1))/(SMA(ABS(CLOSE-LL3),6,1))*100;
LIL2:=(SMA(MAX(CLOSE-LL3,0),13,1))/(SMA(ABS(CLOSE-LL3),13,1))*100;
LIL3:=(BARSLAST(LIL2<24))<=5 AND CROSS(LIL1,LIL2);
LIL4:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100<-12.5;
LIL5:=EMA((CLOSE-LL7)/(LL6-LL7)*100,5);
LIL6:=EMA(0.667*REF(LIL5,1)+0.333*LIL5,5);
西施:=IF(LIL3 AND LIL4 AND CROSS(LIL5,LIL6) AND LIL5<=25,1,0);
LIL7:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND LL4<REF(CLOSE,2) AND (ABS(LL4-LL3))/LL3<0.023 AND CLOSE/OPEN>1.05 AND CLOSE>(REF(CLOSE,2)+REF(OPEN,2))/2;
LIL8:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100<-6;
LIL9:=DMA(CLOSE,VOL/MA(VOL,4)/4);
LIL10:=DMA(CLOSE,VOL/MA(VOL,31)/31);
LIL11:=(CLOSE-LIL9)/LIL9*100<-10;
LIL12:=(LIL9-LIL10)/LIL10*100<-16;
LIL13:=(CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100<-23;
LIL14:=(SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1))/(SMA(ABS(CLOSE-LL3),3,1))*100>16;
LIL15:=100*(HHV(HIGH,27)-CLOSE)/(HHV(HIGH,27)-LLV(LOW,27));
LIL16:=MA(LL1,6);
LIL17:=MA(LL1,24);
LIL18:=MA(LL1,32);
LIL19:=LIL18>LIL16*1.11 AND LIL17>LIL16*1.095;
LIL20:=(LIL11 AND LIL12 AND (OPEN-LL3)/LL3>-0.07 OR LIL13 AND LIL14 AND CROSS(LIL15,79) OR LIL19 AND CLOSE/COST(8)<=0.8)*100;
貂蟬:=LIL7 AND LIL8 OR LIL20;
LIL24:=(CLOSE-OPEN)/OPEN*100;
LIL25:=(SMA(MAX(CLOSE-LL3,0),7,1))/(SMA(ABS(CLOSE-LL3),7,1))*100;
LIL26:=(COUNT(LIL25<20,20))>=4;
LIL27:=(SMA(MAX(CLOSE-LL3,0),7,1))/(SMA(ABS(CLOSE-LL3),7,1))*100;
LIL28:=(SMA(MAX(CLOSE-LL3,0),13,1))/(SMA(ABS(CLOSE-LL3),13,1))*100;
LIL29:=(BARSLAST(LIL28<20))<=3 AND CROSS(LIL27,LIL28);
LIL30:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100<-12.5;
LIL31:=EMA((CLOSE-LL7)/(LL6-LL7)*100,4);
LIL32:=EMA(0.667*REF(LIL31,1)+0.333*LIL31,2);
LIL95:=HHVBARS(HIGH,50);
LIL96:=(CLOSE-REF(OPEN,LIL95))/REF(OPEN,LIL95)*100;
LIL97:=REF(CLOSE,2)*0.865;
LIL98:=REF(CLOSE,13)*0.772;
LIL99:=MIN(LIL97,LIL98);
LIL100:=IF(REF(CLOSE,2)/REF(OPEN,2)<0.95 AND LL4<REF(CLOSE,2) AND LL4=LL3 AND CLOSE/OPEN>1.067 AND CLOSE>REF(CLOSE,2) AND LLV(CLOSE,3)/HHV(CLOSE,55)<0.8 OR LIL24>10 AND CLOSE>MA(CLOSE,190) AND OPEN<MA(CLOSE,200) AND LIL26 AND LL3/REF(CLOSE,2)>0.9 OR LIL29 AND LIL30 AND CROSS(LIL31,LIL32) AND LIL31<=25,1,0);
LIL101:=IF((CLOSE-LIL99)/CLOSE<0.03 AND LIL96<-35 AND SUM(LL10,5)/5<1.8,1,0);
李師師:=LIL100 OR LIL101;
LIL33:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
LIL34:=CLOSE/MA(CLOSE,40)*100<76;
LIL35:=CLOSE/MA(CLOSE,60)*100<74;
LIL36:=HIGH>LOW*1.051;
LIL37:=LIL36 AND COUNT(LIL36,5)>1;
LIL102:=HIGH/LL5>0.98 AND (ABS(HHV(HIGH,60)-LLV(LOW,60)))/CLOSE>0.66 AND (ABS(CLOSE-REF(CLOSE,10)))/CLOSE>0.2;
LIL103:=CLOSE/MA(CLOSE,40)*100<78;
LIL104:=CLOSE/MA(CLOSE,60)*100<74;
LIL105:=HIGH>LOW*1.051;
LIL106:=LIL105 AND COUNT(LIL105,5)>2;
LIL107:=LIL106 AND (LIL103 OR LIL104);
LIL108:=DMA(CLOSE,VOL/SUM(VOL,34));
LIL109:=CLOSE/MA(CLOSE,50)<0.75;
LIL110:=CLOSE/LIL108<0.74;
LIL111:=CLOSE<MA(CLOSE,13)*0.89 AND HIGH/LOW>1.051 AND "DPO">-9 AND MA(VOL,16);
LIL112:=MIN(LIL109,LIL110);
LIL113:=LIL111 AND LIL112;
LIL114:=IF(LIL113 AND LIL107 AND LIL102,1,0);
LIL115:=IF(LIL37 AND (LIL34 OR LIL35) AND REF(LIL33,1)>=10 AND REF(LIL33,1)/LIL33>=1.13 AND CLOSE/LL3>=1.02,1,0);
王昭君:=LIL114 OR LIL115;
LIL38:=DMA(CLOSE,VOL/MA(VOL,4)/4);
LIL39:=DMA(CLOSE,VOL/MA(VOL,32)/32);
LIL40:=(CLOSE-LIL38)/LIL38*100<-8;
LIL41:=(LIL38-LIL39)/LIL39*100<-21;
LIL42:=LIL40 AND LIL41 AND (OPEN>CLOSE OR OPEN<CLOSE) AND (OPEN-LL3)/LL3>-0.05 AND (LL3>LL4 OR LL3<LL4) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5)) AND (REF(OPEN,6)>REF(CLOSE,6) OR REF(OPEN,6)<REF(CLOSE,6)) AND (REF(OPEN,7)>REF(CLOSE,7) OR REF(OPEN,7)<REF(CLOSE,7));
LIL43:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100<-23;
LIL44:=(LL1-LLV(INDEXL,275))/(HHV(INDEXH,275)-LLV(INDEXL,275))*100;
LIL45:=SMA(LIL44,50,1);
LIL46:=SMA(LIL45,40,1);
VARG:=LIL43 AND LIL46<23 AND COUNT(LIL43,2)=1 AND (OPEN>CLOSE OR OPEN<CLOSE) AND OPEN/LL3>0.96;
常娥:=IF(LIL42 OR VARG,1,0);
LIL47:=CLOSE<DMA(EMA(CLOSE,21),SUM(VOL,8)/5/CAPITAL)*(0.76) AND CLOSE<REF(HIGH,13)*0.775 AND "VMACD.MACD"(13,63,10)>0 AND (MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW))+ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100))/(AMOUNT/VOL/100)*50>2.1 AND LL5/HIGH<1.02 AND VOL<REF(VOL,1)*3 AND "KDJ.J"(28,14,7)<10 AND MA(VOL,10)<MA(VOL,50)*1.7;
秦始皇:=IF(LIL47,1,0);
LIL48:=DMA(CLOSE,VOL/MA(VOL,4)/4);
LIL49:=DMA(CLOSE,VOL/MA(VOL,31)/31);
LIL50:=(CLOSE-LIL48)/LIL48*100<-10;
LIL51:=(LIL48-LIL49)/LIL49*100<-16;
LIL52:=LIL50 AND LIL51;
漢武帝:=IF(LIL52 AND (OPEN>CLOSE OR OPEN<CLOSE) AND (OPEN-LL3)/LL3>-0.07 AND (LL3>LL4 OR LL3<LL4) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5)) AND (REF(OPEN,6)>REF(CLOSE,6) OR REF(OPEN,6)<REF(CLOSE,6)) AND (REF(OPEN,7)>REF(CLOSE,7) OR REF(OPEN,7)<REF(CLOSE,7)),1,0);
LIL53:=MA(LL1,6);
LIL54:=MA(LL1,24);
LIL55:=MA(LL1,32);
LIL56:=MA(LL1,62);
LIL57:=MA(LL1,105);
LIL58:=LIL56<REF(LIL56,1) AND LIL57<REF(LIL57,1) AND LIL56<LIL57*0.98;
LIL59:=LIL55>LIL53*1.11 AND LIL54>LIL53*1.095;
LIL60:=LIL53>LIL24*0.95;
唐太宗:=IF(LIL58 AND LIL59 AND LIL60 AND CLOSE/COST(8)<=0.8 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (LL3>LL4 OR LL3<LL4),1,0);
LIL61:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/LL3>0.905 AND CLOSE/LL3<1.05 AND LL10<5,50,0);
LIL62:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100;
LIL63:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
LIL64:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100;
BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
LIL65:=(LIL62+LIL63+LIL64+BIAS1+BIAS2+BIAS3)/6;
LIL66:=ABS(BIAS1-BIAS3);
LIL67:=(LIL65+LIL66)/2;
LIL68:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
LIL69:=LIL68+LIL67;
LIL70:=IF(LIL61>0 AND LIL69<0,200,0);
LIL71:=IF(LIL67<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/LL3>0.905 AND CLOSE/LL3<1.05 AND LL10<5,-50,0);
LIL72:=IF(LIL69<0 AND LIL71=-50,100,0);
LIL73:=REF(CLOSE,2)*0.865;
LIL74:=REF(CLOSE,13)*0.772;
LIL21:=MIN(LIL73,LIL74);
LIL22:=IF((CLOSE-LIL21)/CLOSE<3/100 AND SUM(LL10,5)/5<1.8,1,0);
LIL23:=IF(LIL22>0 AND (LIL71<0 OR LIL61>0),100,0);
LIL87:=(LIL70>0 AND LIL72>0 AND SUM(LL10,5)/5<1 OR LIL22>0) AND (LIL71<0 OR LIL61>0);
LIL88:=LIL70>0 AND LIL72>0 AND SUM(LL10,5)/5<1 OR LIL22>0 AND LL3/REF(CLOSE,2)>0.902;
LIL89:=LIL87 OR LIL88;
LIL90:=LIL23 OR LIL89;
LIL91:=MA(CLOSE,80)-MA(CLOSE,10)/3;
LIL92:=IF(LIL90>0,1,0);
LIL93:=IF(LIL23>0,1,0);
LIL94:=IF(LIL23>0 AND CLOSE<LIL91,1,0);
成吉思汗:=LIL92 OR LIL93 OR LIL94;
P:西施 OR 貂蟬 OR 李師師 OR 常娥 OR 秦始皇 OR 漢武帝 OR 唐太宗 OR 成吉思汗 OR 王昭君;
L天驕3號F
X1:=ABS(MA(CLOSE,20)/MA(CLOSE,250)-1)<0.02;
X2:=ABS(MA(CLOSE,60)/MA(CLOSE,250)-1)<0.02;
X3:=ABS(MA(CLOSE,20)/MA(CLOSE,60)-1)<0.02;
X4:=ABS(MA(CLOSE,20)/MA(CLOSE,125)-1)<0.02;
X5:=ABS(MA(CLOSE,60)/MA(CLOSE,125)-1)<0.02;
X6:=ABS(MA(CLOSE,250)/MA(CLOSE,125)-1)<0.02;
X7:=ABS(MA(CLOSE,20)/MA(CLOSE,40)-1)<0.02;
X8:=ABS(MA(CLOSE,20)/MA(CLOSE,90)-1)<0.02;
X9:=ABS(MA(CLOSE,40)/MA(CLOSE,60)-1)<0.02;
X10:=ABS(MA(CLOSE,40)/MA(CLOSE,90)-1)<0.02;
X11:=ABS(MA(CLOSE,40)/MA(CLOSE,125)-1)<0.02;
X12:=ABS(MA(CLOSE,40)/MA(CLOSE,250)-1)<0.02;
X13:=ABS(MA(CLOSE,60)/MA(CLOSE,90)-1)<0.02;
X14:=ABS(MA(CLOSE,90)/MA(CLOSE,125)-1)<0.02;
X15:=ABS(MA(CLOSE,90)/MA(CLOSE,250)-1)<0.02;
粘和:X1 AND X2 AND X3 AND X4 AND X5 AND X6 AND X7 AND X8 AND X9 AND X10 AND X11 AND X12 AND X13 AND X14 AND X15,STICK,colorFF;

文件:q天驕公式組_hy.alg
名稱: L天驕3號Z 類別:技術指標
說明: ******粘合均線主圖
公式組: 力量
二十:MA(CLOSE,20);
四十:MA(CLOSE,40);
六十:MA(CLOSE,60);
九十:MA(CLOSE,90);
一二五:MA(CLOSE,125);
二五零:MA(CLOSE,250);
X1:=ABS(MA(CLOSE,20)/MA(CLOSE,250)-1)<0.02;
X2:=ABS(MA(CLOSE,60)/MA(CLOSE,250)-1)<0.02;
X3:=ABS(MA(CLOSE,20)/MA(CLOSE,60)-1)<0.02;
X4:=ABS(MA(CLOSE,20)/MA(CLOSE,125)-1)<0.02;
X5:=ABS(MA(CLOSE,60)/MA(CLOSE,125)-1)<0.02;
X6:=ABS(MA(CLOSE,250)/MA(CLOSE,125)-1)<0.02;
X7:=ABS(MA(CLOSE,20)/MA(CLOSE,40)-1)<0.02;
X8:=ABS(MA(CLOSE,20)/MA(CLOSE,90)-1)<0.02;
X9:=ABS(MA(CLOSE,40)/MA(CLOSE,60)-1)<0.02;
X10:=ABS(MA(CLOSE,40)/MA(CLOSE,90)-1)<0.02;
X11:=ABS(MA(CLOSE,40)/MA(CLOSE,125)-1)<0.02;
X12:=ABS(MA(CLOSE,40)/MA(CLOSE,250)-1)<0.02;
X13:=ABS(MA(CLOSE,60)/MA(CLOSE,90)-1)<0.02;
X14:=ABS(MA(CLOSE,90)/MA(CLOSE,125)-1)<0.02;
X15:=ABS(MA(CLOSE,90)/MA(CLOSE,250)-1)<0.02;
粘和:=X1 AND X2 AND X3 AND X4 AND X5 AND X6 AND X7 AND X8 AND X9 AND X10 AND X11 AND X12 AND X13 AND X14 AND X15;
DRAWICON(粘和,二五零,8);

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  输入号码查询新疆35选7